NOWE POSTY | NOWE TEMATY | POPULARNE | STAT | RSS | KONTAKT | REJESTRACJA | Login: Hasło: rss dla

HOME » D-STAR ICOM DV » MMDVM HOTSPOT PI-STAR

Przejdz do dołu strony<<<Strona: 5 / 7>>>    strony: 1234[5]67

MMDVM hotspot Pi-star

  
SQ9MUR
11.01.2019 11:03:33
poziom 5

Grupa: Użytkownik

QTH: Tarnów

Posty: 700 #2626999
Od: 2009-9-23


Ilość edycji wpisu: 1
Pistar to linux jak wyłączysz kilka razy zasilanie bez zamknięcia systemu, to takie cuda z kartą mogą się dziać, ewentualnie gdy karta sd jest uszkodzona. Standardowo nie ma problemu z zapisem ustawień, sam mam bramkę i jeśli coś takiego się dzieje tzn, że albo system plików się wysypał albo z jakimś błędem obraz jest przeniesiony do karty pamięci.
Sposób który podałem jest najszybszy i najłatwiejszy.
_________________
Maciek SQ9MUR
RPT:
DMR SR9TR
DMR SR9VDM
FM SR9VO
  
Electra19.09.2019 21:04:36
poziom 5

oczka
  
SO5AJG
12.01.2019 15:51:16
poziom 3

Grupa: Użytkownik

QTH: KO02ME, Warszawa

Posty: 143 #2627321
Od: 2013-11-2
Czy poprzez platformę SSH można zmienić ustawienie aktualne (ro) na (rw) i wówczas każda zmiana w konfiguracji będzie zapisana na karcie microSD. Tak zresztą mam na drugim hotspocie, gdzie po zalogowaniu się na SSH wyświetla się informacja - enable read-write with "rpi-rw" (rw) i w tym HS nie mam problemu z zapisywaniem zmian, natomiast na tym pierwszym HS po zalogowaniu jest (ro)-read only. Wygodniej byłoby dokonać zmiany z poziomu SSH, czy rzeczywiście trzeba od nowa przeinstalować obraz na karcie. Mam jeszcze jeden problem nie zawsze czas synchronizuje się na obu HS. Czasami oba zsynchronizują się bez problemu a innym razem tylko jeden i nie zawsze ten sam.
_________________
73 Janusz SO5AJG
  
sp2ong
12.01.2019 17:14:26
poziom 3



Grupa: Użytkownik

QTH: Torun

Posty: 198 #2627348
Od: 2013-11-29
Po zalogowaniu sie na PI-star napisz polecnie:

rpi-rw

mozesz wtedy uzywajac edytor wprwadzac zmiany w konfiguracji

Polecam zainstalowac sobie komandera:

sudo apt-get install mc

i uruchomic go:

sudo mc


_________________
73 Waldek SP2ONG
http://sp2ong.noip.pl
  
SO5AJG
12.01.2019 18:17:45
poziom 3

Grupa: Użytkownik

QTH: KO02ME, Warszawa

Posty: 143 #2627366
Od: 2013-11-2
Dzięki za informacje. Widzę, że to taki Norton Commander jak się kiedyś używało. Podgladane katalogi niestety nie wszystko mi mówią, także ostrożnie trzeba zmieniać. Czy możliwa jest na trwale taka zmiana, aby stale było ustawienie na rw, bo każdorazowo po zmianie na SSH (wcześniej ustawione na rpi-rw) system przy wychodzeniu z SSH przechodzi automatycznie na (ro) i dlatego wszystkie zmiany z poziomu dashboarda działają do momentu wyłączenia zasilania (a to muszę na wieczór robić). W drugim HS stan rw utrzymuje się tylko dlatego, że pojawił się jakiś błąd i po wyjściu z SSH pojawia się zapis mount: / is busy i stan rw nie jest zamieniany ro, taką przynajmniej informację wyczytałem na jakimś forum. Przy okazji parę pomocnych ciekawostek znalazłem na Twojej stronie WWW.
_________________
73 Janusz SO5AJG
  
SQ9MUR
12.01.2019 18:18:02
poziom 5

Grupa: Użytkownik

QTH: Tarnów

Posty: 700 #2627367
Od: 2009-9-23
Nie ma to znaczenia przy zapisie przez panel www. Skoro nie zapisuje zmian, to coś sie wysypało. Zrob kopie zapasową ustawień. Wgraj świeży obraz przywróć z kopii zapasowej ustawienia. Po tej operacji zrob dodatkowe zmiany i zapisz.
_________________
Maciek SQ9MUR
RPT:
DMR SR9TR
DMR SR9VDM
FM SR9VO
  
sp2ong
12.01.2019 19:12:56
poziom 3



Grupa: Użytkownik

QTH: Torun

Posty: 198 #2627394
Od: 2013-11-29


Ilość edycji wpisu: 2
Janusz,

jak sie logujesz via ssh to pisze

Pi-Star's disk is read-only by default, enable read-write with "rpi-rw".

Pi-star domyslnie jest caly czas w trybie RO

komendy rpi-ro - rpi-rw to aliasy komend

alias rpi-ro='sudo mount -o remount,ro / , sudo mount -o remount,ro /boot'
alias rpi-rw='sudo mount -o remount,rw / , sudo mount -o remount,rw /boot'

ale patrzac na /etc/fstab wyglada ze zawsze po reboot i wylaczeniu zasilania bedzie pracowac w trybie RO bo taka idea byla autora oczywiscie uzywaja interfejsu WWW podczas zapisywania konfiguracji przelaczany jest w tryb RW i po zapisie wraca do RO

Ja mam wersje 3.4.17

Choc bywaja problemy z komendami rpi-ro i rpi-rw patzr tu:

https://amateurradionotes.com/pi-star-troubleshooting.htm

wlasnie jest tam opisany problem komunikatu: mount: / is busy
jak pisza nalezt zrobic reboot co wraca w tryb RO bo w /etc/fstab jest ze ma byc RO tryb po bootowaniu systemu


Co do synchronizacji czasu to widac cos nie tak jest skoro w wersji 4.0 RC2 pisze autor:

NTP Support Improved
NTP support has been improved, Pi-Star should do a much improved
job of jumping to the correct time after boot up, and staying
on time correctly.

tzn zostalo cos poprawione

_________________
73 Waldek SP2ONG
http://sp2ong.noip.pl
  
SO5AJG
12.01.2019 19:44:36
poziom 3

Grupa: Użytkownik

QTH: KO02ME, Warszawa

Posty: 143 #2627400
Od: 2013-11-2
Właśnie teraz zrobiłem upgrade do wersji 3.4.17. Nie wiem, czy w tym nie zapamiętywaniu zmian w konfiguracji nie miały wpływu zmiany, które wprowadzałem poprzez SSH wykonując modyfikację na podstawie opisu Rogera Clarka
a dotyczące montażu przełącznika umożliwiającego szybką zmianę w HS z Brandmeistera na DMR+ i odwrotnie w ciągu praktycznie 3 sek., bo zastosowany Gateway uprzywilejowuje BM w stosunku do DMR+. Można oczywiście zrobić odpowiednie zmiany w konfiguracji przekierowań TGRewrite w zakładce DMR GW - DMR Network 2, ale o tym wcześniej nie wiedziałem. Tę stronę z błędami to właśnie czytałem i pewnie występują w tym moim drugim HS, ale to akurat mi nie przeszkadza, bo poza tym nie mam z nim żadnym problemów, to jest wersja HS, która współpracuje z płytką modemową do pracy duplexowej.
_________________
73 Janusz SO5AJG
  
SO5AJG
13.01.2019 13:02:29
poziom 3

Grupa: Użytkownik

QTH: KO02ME, Warszawa

Posty: 143 #2627577
Od: 2013-11-2
Waldku,
Próbowałeś tę wer. 4.0 RC2, bo ja wgrałem ten obraz na kartę, ale Pi-star nie startuje. Gdzie można znaleźć opis tej wersji, bo jakoś nie udało mi się.
_________________
73 Janusz SO5AJG
  
SQ9MUR
13.01.2019 14:57:54
poziom 5

Grupa: Użytkownik

QTH: Tarnów

Posty: 700 #2627598
Od: 2009-9-23
    SO5AJG pisze:

    Waldku,
    Próbowałeś tę wer. 4.0 RC2, bo ja wgrałem ten obraz na kartę, ale Pi-star nie startuje. Gdzie można znaleźć opis tej wersji, bo jakoś nie udało mi się.


Wgrałeś na kartę sd plik z konfiguracją sieci?
http://www.pistar.uk/wifi_builder.php
_________________
Maciek SQ9MUR
RPT:
DMR SR9TR
DMR SR9VDM
FM SR9VO
  
SQ9MUR
13.01.2019 15:01:05
poziom 5

Grupa: Użytkownik

QTH: Tarnów

Posty: 700 #2627599
Od: 2009-9-23
    SQ9MUR pisze:

      SO5AJG pisze:

      Waldku,
      Próbowałeś tę wer. 4.0 RC2, bo ja wgrałem ten obraz na kartę, ale Pi-star nie startuje. Gdzie można znaleźć opis tej wersji, bo jakoś nie udało mi się.


    Wgrałeś na kartę sd plik z konfiguracją sieci?
    http://www.pistar.uk/wifi_builder.php


U mnie ruszyło od razu na jumbospot po przywróceniu kopii konfiguracji z wersji 3.4.17
Drugi hotspot z stm32 miał pewne braki i musiałem zrobić korektę ustawień.
_________________
Maciek SQ9MUR
RPT:
DMR SR9TR
DMR SR9VDM
FM SR9VO
  
SO5AJG
13.01.2019 16:44:35
poziom 3

Grupa: Użytkownik

QTH: KO02ME, Warszawa

Posty: 143 #2627634
Od: 2013-11-2
U mnie coś jest jednak nie tak, bo pomimo skopiowania backupu poprzedniej konfiguracji i pliku ustawień sieci WiFi nadal HS nie startuje. Zresztą na poprzedniej wersji 3.4.17 i jeszcze wcześniejszej 3.4.16 miałem problem ze startem systemu po wyłączeniu zasilania. Zwykle dwu- lub trzykrotne załączenie zasilania jedno po drugim HS startuje. Natomiast dopóki nie wyłączy się zasilania może pracować bardzo długo. Także generalnie ma trudny start i być może dlatego nie mogę uruchomić tego nowego systemu 4.0
_________________
73 Janusz SO5AJG
  
Electra19.09.2019 21:04:36
poziom 5

oczka
  
SO5AJG
15.01.2019 18:14:05
poziom 3

Grupa: Użytkownik

QTH: KO02ME, Warszawa

Posty: 143 #2628260
Od: 2013-11-2
Problem ze startem systemu wynikał z uszkodzenia kabla, które początkowo było nie zauważalne. Nadal nie daje się uruchomić wer. 4.0 RC2
_________________
73 Janusz SO5AJG
  
SQ9MUR
15.01.2019 20:12:45
poziom 5

Grupa: Użytkownik

QTH: Tarnów

Posty: 700 #2628292
Od: 2009-9-23
    SO5AJG pisze:

    Problem ze startem systemu wynikał z uszkodzenia kabla, które początkowo było nie zauważalne. Nadal nie daje się uruchomić wer. 4.0 RC2



Wgrałeś plik konfiguracyjny sieci wifi?
Na pierwszy start trzeba troszkę dłużej poczekać
_________________
Maciek SQ9MUR
RPT:
DMR SR9TR
DMR SR9VDM
FM SR9VO
  
SO5AJG
15.01.2019 21:17:56
poziom 3

Grupa: Użytkownik

QTH: KO02ME, Warszawa

Posty: 143 #2628313
Od: 2013-11-2
Już jest OK. Mimo, że wgrywałem ten plik konfiguracyjny wifi nic z tego nie wychodziło. Podejrzewam, że dwie sprawy nałożyły się równocześnie a mianowicie ten uszkodzony kabelek a i to, że zasugerowałem się brakiem informacji na wyświetlaczu. Dlatego nie mogłem dostać się w przeglądarce na swoje IP pod którym wchodziłem na wersję 3.4.17. Nawet zgodnie z opisem pistara miałem wgrany do partycji bootującej plik zip backupowy.
Najbardziej bruździł mi ten kabelek i dlatego nie mogłem zorientować się w czym leży przyczyna. Dopiero przypadkowo zauważyłem, że ruszając wtykiem microUSB przygasają mi LED-y. Myślałem, że to od tego wtykania obruszało się gniazdo zasilania, okazało się, że to jednak w kablu.
Dzięki za pomoc.

_________________
73 Janusz SO5AJG
  
SO5AJG
17.01.2019 15:24:40
poziom 3

Grupa: Użytkownik

QTH: KO02ME, Warszawa

Posty: 143 #2628723
Od: 2013-11-2
Mam pytanie związane z wer. 4.0 RC2, czy ktoś kto używa aplikacji Pi-star Mobile na Androida sprawdził, czy działa ona przy tej wer. 4.0, bo u mnie nie. Przy poprzedniej w tym ostatniej 3.4.17 nie było z tym problemu.
Być może do twórcy tej wersji mobilnej jeszcze 4.0RC2 nie dotarło.
_________________
73 Janusz SO5AJG
  
sp2ong
17.01.2019 16:43:34
poziom 3



Grupa: Użytkownik

QTH: Torun

Posty: 198 #2628747
Od: 2013-11-29


Ilość edycji wpisu: 1
Zwroc uwage ze na stronie tej aplikacji jest napisane:

"Pi-Star mobile 1.40 is released.

====== THIS PROJECT IT NO LONGER BEING DEVELOPED) ======
"

http://amateurradio.digital/pistar.php





    SO5AJG pisze:

    Mam pytanie związane z wer. 4.0 RC2, czy ktoś kto używa aplikacji Pi-star Mobile na Androida sprawdził, czy działa ona przy tej wer. 4.0, bo u mnie nie. Przy poprzedniej w tym ostatniej 3.4.17 nie było z tym problemu.
    Być może do twórcy tej wersji mobilnej jeszcze 4.0RC2 nie dotarło.

_________________
73 Waldek SP2ONG
http://sp2ong.noip.pl
  
SO5AJG
17.01.2019 19:23:49
poziom 3

Grupa: Użytkownik

QTH: KO02ME, Warszawa

Posty: 143 #2628787
Od: 2013-11-2
To się zgadza, ale niekoniecznie musiało to oznaczać, że nie odpali na nowej wersji. Wszystko zależy od tego jakie zmiany wprowadzono, czy akurat takie, które uniemożliwią pracę wersji mobilnej. Akurat nie zaglądałem od razu na tę stronę, bo wpisy odpowiednich komend miałem skopiowane do swojego pliku. W poprzedniej wersji też miałem problemy, ale powtórne wgranie tego programu chyba dwa razy w końcu powiodło się, myślałem, że tutaj może być ten sam problem. Ponadto na innej stronie znalazłem również nieco inne (podobne) komendy dotyczące tego samego programu, ale to również nie pomogło. Ta wersja 4.0RC2 to w końcu wersja beta i być może niektóre ustawienia mogą być jeszcze zmienione w wersji finalnej - zobaczymy.
_________________
73 Janusz SO5AJG
  
sp2ong
17.01.2019 20:24:10
poziom 3



Grupa: Użytkownik

QTH: Torun

Posty: 198 #2628802
Od: 2013-11-29
No tak zapomnialem dopisac ze podone problemy zglaszane sa na forum pistar.uk i miedzy innymi byla ta informacja ze nie dziala aplikacja na ver4.x PI-Star

_________________
73 Waldek SP2ONG
http://sp2ong.noip.pl
  
SO5AJG
17.01.2019 22:41:51
poziom 3

Grupa: Użytkownik

QTH: KO02ME, Warszawa

Posty: 143 #2628853
Od: 2013-11-2
    sp2ong pisze:

    No tak zapomnialem dopisac ze podone problemy zglaszane sa na forum pistar.uk i miedzy innymi byla ta informacja ze nie dziala aplikacja na ver4.x PI-Star


Dzięki za info. Widocznie zbyt pobieżnie przeglądałem to forum i nie natrafiłem na ten temat. Czasami zbyt duża ilość tematów stron i nie ma cierpliwości, żeby to wszystko przejrzeć.
_________________
73 Janusz SO5AJG
  
sp2ong
18.01.2019 07:38:47
poziom 3



Grupa: Użytkownik

QTH: Torun

Posty: 198 #2628889
Od: 2013-11-29


Ilość edycji wpisu: 2
Janusz, bo to bylo przy okazji innego watku VK3KYY pisal o tym tu:

https://forum.pistar.uk/viewtopic.php?f=3&t=1237&p=5340&hilit=pistar+mobile#p5342
_________________
73 Waldek SP2ONG
http://sp2ong.noip.pl
  
Electra19.09.2019 21:04:36
poziom 5

oczka

Przejdz do góry strony<<<Strona: 5 / 7>>>    strony: 1234[5]67

  << Pierwsza     < Poprzednia      Następna >     Ostatnia >>  

HOME » D-STAR ICOM DV » MMDVM HOTSPOT PI-STAR

Aby pisac na forum musisz sie zalogować !!!

randki | własny sklep internetowy | promocje | CyberCiekawostki | darmowe forum | sklepy
opinie, testy, oceny | katalog stron | toplsta