NOWE POSTY | NOWE TEMATY | POPULARNE | STAT | RSS | KONTAKT | REJESTRACJA | Login: Hasło: rss dla

HOME » DIY - KONSTRUKCJE » MOTOROLA GM900 I PROBLEMY...

Przejdz do dołu stronyStrona: 1 / 1    strony: [1]

Motorola Gm900 i problemy...

Prośba o pomoc przy GM900
  
SP9MK
04.05.2016 17:48:47
poziom 4

Grupa: Użytkownik

QTH: Mysłowice

Posty: 349 #2279056
Od: 2016-5-4
Witajcie.

W internecie jest dużo "szumu" i nic sensownego wyłapać nie umiem a rib nie jest lekarstwem na wszystko...

To tak w ramach wstępu.

Wykonałem swojej konstrukcji RIB'a opartego o PL2303HX a aby dopełnić dzieła komunikację odpaliłem pod win 7 x64 bit.
Kabelek jest w zasadzie klonem RIB'a z wyprowadzonymi potrzebnymi sygnałami i dopasowany do PL2303HX (ma zanegowane linie sterujące i pracuje z logiką 3.3V).

Program oczywiście RSS R06.03.00 odpalony w DosBox. Rs232 poprawnie skonfigurowany z wyłączonym buforem.

Genralnie kabel działa. W terminalu mam echo. Wystawienie stanu wysokiego przez DTR daje sygnał na CTS i RI.
Sama transmisja też działa. Widzę efekt próby komunikacji przez postawienie zanegowanego BUSY w stan wysoki i linię danych nadającą w ascii SOH i STX.

Sygnały lini BUS+ i BUS- są takie same i zanegowane. Kabelek RJ45 też jest dobrze podłączony bo widzę pullup od strony radia dla BUS+ i pulldown dla BUS-.

W czasie próby nawiązania połączenia zanegowana linia BUSY idzie na stan wysoki (nie jestem pewien i prosił bym o weryfikację).

Program natomiast wyrzuca mi komunikat "Bus data collision on TX error".

Próbowałem zmieniać prędkość "procesora" w emulatorze i efekt na oscyloskopie widzę w postaci dłuższych przerw między ramkami danych ale komunikacji z radiem nie udało mi się nawiązać.

Każda sugestia może być bezcenna.

Pozdrawiam SP9MK
  
Electra20.08.2018 02:46:10
poziom 5

oczka
  
SO5AD
04.05.2016 21:12:24
poziom 4

Grupa: Użytkownik

QTH: KO02LE

Posty: 256 #2279150
Od: 2014-6-23


Ilość edycji wpisu: 6
    SP9MK pisze:

    Witajcie.
    ...Każda sugestia może być bezcenna.

    Pozdrawiam SP9MK


Cześć
Ja sobie darowałem odpalanie dosowych programów w zwirtualizowanym/emulowanym środowisku

Bawiłem się na VMware Workstation radiem GM300, M216
- GM350 działa na wirtualnej maszynie z Win 98
- GM 300 i M216 nie działa na tej samej maszynie odpalonej w DOS - "Invalid opcode error" czy jakoś tak

Jeśli masz maszynę z RS232 i możesz ją uruchomić z pendrive
zrób sobie bootowalnego pendrive z DOS przy pomocy Rufus z https://rufus.akeo.ie/ ja używałem rufus-1.4.12.exe
wrzuć wszystkie programy, dodaj NC albo VC do zarządzania plikami.

Jak tak mam zrobione i dzięki temu sprawnie chodzi software do
YAESU FTL1011, Motorola GM300, M216 na maszynie z 2006 roku z Pentium 4 3GHz | 3GB RAM

W niestandardowych konfiguracjach programowanie nawet przy pomocy oryginalnego RIBa
stwarzało czasem problemy a co dopiero mówić o własnoręcznie wykonanym + niestandardowe środowisko
dla samego programu.

Ćwiczyłem jeszcze Laptopa z i7|16GB RAM|Windows 7 na nim VMware Workstation 9 z maszyną Windows 98 do programowania w DOS i Windows,
do tego laptop już nie posiada RS232 i musiałem użyć przejściówki USB-RS232 na chipsecie Prolific - radia niby jakoś reagowały
ale ostatecznie nie uzyskałem pożądanego efektu i zaniechałem dalszych prób.
_________________
Artur Dębski
SO5AD (ex:SO5AGV)
SWL SP5-25-779
145.500 & 439.650 & 70.260
http://blogit.one.pl
  
SQ3NQH
04.05.2016 22:38:12
poziom 2

Grupa: Użytkownik

QTH: Krotoszyn JO81RQ

Posty: 65 #2279194
Od: 2011-4-17
Witaj Marcin.
Na początek polecam wykluczyć podstawową sprawę, mianowicie czy radio komunikuje się w sposób tradycyjny (RIB/wolny komp/soft DOS). Znajdź kogoś w okolicy z tym sprzętem.Piszę to dla tego że trafiły mi się kiedyś dwie gm900 z defektem komunikacji, wszystko działało prawidłowo RX/TX klawisze panelu itp jednak radia nie dało się programować.Po czasie odkryłem że wpływ na komunikację z radiem ma jego temperatura.Te radia mają około 20 lat, nawet leżaki magazynowe po tym czasie mają elektroniczne kaprysy.Jeśli będziesz na ŁOŚiu to będziesz miał możliwość weryfikacji. Ja napewno zabiorę RIBa i soft do gm900. Być może koledzy rozwiną wątek temperaturowy, osobiście nie wnikałem co w tych radiach rozjeżdża się od temp.Pozdrawiam oczko
_________________
Pozdrawiam Łukasz SQ3NQH
  
SP9MK
05.05.2016 07:25:51
poziom 4

Grupa: Użytkownik

QTH: Mysłowice

Posty: 349 #2279251
Od: 2016-5-4
Witaj Łukasz.

Słuchaj miałbyś może chwilkę czasu (i choć niekoniecznie oscyloskop)? Chciałbym porównać komunikację Twojego rib'a z moim. Mogłem się gdzieś pomylić w stanach logicznych choć schemat analizowałem z 20 razy.

Pierwsze co potrzebuję to sprawdzenie programem terminalowym czy rib na pewno pracuje z echem oraz czy wystawienie DTR powoduje aktywację RI oraz CTS.

Generalnie program wysyła na RS i próbuje komunikować się z radiem. Lecz czy jest radio podłączone czy go brak to reakcja programu (i danych na linii) identyczna zmieszany.

Chciałem zrobić coś nowego i ułatwić życie innym kolegom bo koszt takiego kabla nie przekracza 20zł (choć to może też zabić pewien mały "biznes").

Samo radio fajne, na te kilka przemienników i parę bezpośrednich do mobila jak się patrzy oczko

Sprawdzałem też PCB na przednim panelu bo podobno ścieżki przecinają ale wygląda ok.
  
SQ3NQH
05.05.2016 23:44:41
poziom 2

Grupa: Użytkownik

QTH: Krotoszyn JO81RQ

Posty: 65 #2279692
Od: 2011-4-17
Do sprzętu z lat 90 będę miał chwile w nadchodzący weekend. Postaram się zarejestrować wszystkie przebiegi podczas prawidłowej komunikacji PC-RIB-GM900. Zrobię video. Jesli chodzi o program terminalowy to podaj nazwę ja to robię z poziomu DOSa, coś kiedyś było pod dosem do słuchania portu. Ale i tak za wiele to pod dosem nie pomoże.Pod windows 98 można skutecznie nawiązać komunikację z MC2100/GM1200 przy pomocy wookie (podobne radio ten sam rib)w tym przypadku może terminalowo było by coś widać. Masz zacięcie i chęci na radiowe eksperymenty bardzo szczęśliwy .W tym przypadku jestem ciekaw czy po opanowaniu komunikacji PL2303HX-GM900 będzie powtarzalność komunikacji w zależności od zastsowanego komputera PC. Wykonałem sobie programator do icoma (ic-f410) przy pomocy właśnie PL2303HX, w tym przypadku działa to w miarę stabilnie choć zdarzyło się scalakowi nie odbierać danych podczas odczytu (windows XP). Co do starego tradycyjnego RIBa, koszt wykonania nie jest tragiczny. Faktem jest że nie wszędzie kupimy scalaki i brakujące elementy płacze . Niestety motorole są z lat 90, wtedy na topie był DOS, wszystko musiało opierać się na tradycyjnych w żaden sposób nie emulowanych i fizycznych portach COM lub LPT . Stare komputery powoli wymierają płacze przed każdym uruchomieniem moich zabytków zastanawiam się czy dadzą radę. Obecnie mam do tego celu laptopa P3 700MHz z wyłączonym cache procesora.Co do softu do GM900 to trzeba go pod dosem zainstalować, wersje które krążą jako backup katalogu też mogą nie działać nawet w swoim macierzystym środowisku.Oprogramowanie tworzy swój własny katalog o domyślnej nazwie MRSS i tam instaluje soft.
_________________
Pozdrawiam Łukasz SQ3NQH
  
SP9MK
06.05.2016 00:21:08
poziom 4

Grupa: Użytkownik

QTH: Mysłowice

Posty: 349 #2279699
Od: 2016-5-4
Terminal pobierz z tego linku (mam identyczny więc będzie łatwiej).
http://wyslijto.pl/plik/to3c0i3wwg

Na początek interesuje mnie (dowolny system) czy po odpaleniu i połączeniu pisząc w dolnym szarym polu widzisz to samo w górnym polu. Jak byś miał chwilkę to sprawdź przy 19200.

Kolejna sprawa która mnie interesuje co się dzieje po zaznaczeniu kontrolki DTR i RTS (identyczne ikonki tylko na górze DSR RI oraz CD i CTS).

Fajnie jakbyś zmierzył napięcie na lini BUSY.
To w zasadzie na początek mi wystarczy. Obecnie gdzieś błądzę i niepotrafię określić czy to soft czy system czy kabel a i może radio.

Ja wiem, że najlepiej zrobić klon riba i jeśli trzeba będzie to w ostateczności zrobię (nie mam odpowiedniego komputera).
  
SP9MK
07.05.2016 11:12:55
poziom 4

Grupa: Użytkownik

QTH: Mysłowice

Posty: 349 #2280300
Od: 2016-5-4
Zrobiłem Motorolowego RIB'a. Stany logiczne zgodnie z moim poprzednim interfacem.

Pod DosBox dokładnie ten sam komunikat z którym walczyłem.
Znalazłem starego laptopa 600MHz (obecnie 200MHz bez cache procesora) z fizycznym RS232 i uruchomiłem z dyskietki startowej win98. Bez podłączonego radia mam komunikat "NAK ERROR" a z podłączonym "Timeout Error".

Gdzie grzebnąć dalej? mam wrażenie, że ciut jeszcze do szczęścia brakuje wesoły
  
SP9MK
07.05.2016 14:30:40
poziom 4

Grupa: Użytkownik

QTH: Mysłowice

Posty: 349 #2280353
Od: 2016-5-4
Chyba początkowy sukces. Zamieniłem w kablu busy i radio chyba wchodzi w tryb programowania (zapala wszystkie segmenty i zwiększa się pobór prądu z zasilacza).

Niestety dalej timeout error. Komputer z którego pracuję obecnie ma wyłączone cache oraz spowolniony procesor do 100MHz. Pracuję na MS DOS z dyskietki startowej W98.

Idę w dobrym kierunku?
  
SQ3NQH
08.05.2016 22:28:03
poziom 2

Grupa: Użytkownik

QTH: Krotoszyn JO81RQ

Posty: 65 #2280880
Od: 2011-4-17
[yt]https://youtu.be/SbDX1xKjJas[/yt]
Proszę o wyrozumiałość aniołek

_________________
Pozdrawiam Łukasz SQ3NQH
  
SP9MK
09.05.2016 08:44:30
poziom 4

Grupa: Użytkownik

QTH: Mysłowice

Posty: 349 #2280996
Od: 2016-5-4
Dzięki!!! Przynajmniej wiem jak to wygląda wesoły.

Jeszcze wielka prośba. Zmierz napięcie na lini BUSY w stanie statycznym.

Wizę, że masz oprogramowanie w wersji R06.06.00 z tego co się zorientowałem (znalazłem w googlach) to jest soft do GP900. Czy to robi jakieś problemy?

Mógłbyś w całej swojej dobroci podesłać mi pliki do wyłączenia cache pod dosem?
Robiłem takie numery ale w biosie więc warto spróbować.

Wczoraj robiłem próby z programowaniem via złącze akcesoriów i zachowanie takie same jak z RJ45. W moim przypadku radiotelefon wchodzi w dziwny stan. Zapala wszystkie segmenty na wyświetlaczu dokładnie tak jak u Ciebie pod koniec transmisji (tuż przed resetem). Pobór prądu zgodny z Twoją sztuką tak więc ok.

Mój komputer to celeron 600MHz 192Mb ram.
  
SP9MK
09.05.2016 10:44:39
poziom 4

Grupa: Użytkownik

QTH: Mysłowice

Posty: 349 #2281088
Od: 2016-5-4
Na początek sprawdzenie Rib'a
Schemat:
http://www.repeater-builder.com/motorola/rss/pix/rln4008schem.gif

Busp - bus+, Busn - bus- Busy - dwa różne stany ale o tym później.

Sygnał bus+ i wyjście (kolektor tranzystora Q7).
http://obrazki.elektroda.pl/5787805800_1462782818.png

Wg. mnie wygląda bardzo przyzwoicie.

Teraz komunikacja z samym radiem.
Stan radia: Reaguje na próbę odczytu przez zapalenie wszystkich segmentów wyświetlacza.

Linia busy radia podłączona do wyprowadzenia 8 riba (Busy bez negacji).

http://obrazki.elektroda.pl/7040708700_1462782821.png
http://obrazki.elektroda.pl/7887258100_1462782821.png

Linia busy podłączona pod zanegowaną linię busy (podającą + zasilania). Radio bez reakcji, kontrolki nie reagują na jakąkolwiek próbę transmisji (brak zachowania jak na Twoim filmie).

http://obrazki.elektroda.pl/4635409500_1462782822.png
http://obrazki.elektroda.pl/2281616100_1462782822.png

W każdym z powyższych przypadków mam wyłączony w biosie cache procesora i program ładuje się w podobnym czasie jak ten na filmie.

Jest jeszcze jedna różnica którą znalazłem. Mianowicie Twoje radio startuje od kanału 01 a moje ma tylko 6 kanałów oznaczonych C1 do C6 ale to chyba bez znaczenia?

Pozdrawiam.

Ps. Dosbox z konwerterem PL2303 i dos z fizycznym portem RS232 daje identyczne przebiegi wesoły
  
Electra20.08.2018 02:46:10
poziom 5

oczka
  
SQ3NQH
09.05.2016 12:14:20
poziom 2

Grupa: Użytkownik

QTH: Krotoszyn JO81RQ

Posty: 65 #2281143
Od: 2011-4-17
http://www.agh-technik.orgfree.com/archiv/cache.zip tu do pobrania soft do zwalniania PC pod system DOS.
_________________
Pozdrawiam Łukasz SQ3NQH
  
SQ3NQH
09.05.2016 13:17:37
poziom 2

Grupa: Użytkownik

QTH: Krotoszyn JO81RQ

Posty: 65 #2281182
Od: 2011-4-17
http://agh-technik.orgfree.com/gif/gm900.gif Jeszcze jedno Marcinie, kabel rib-gm900 z rezystorem taki jak w załączniku.
Rib tylko zasilony (odłączony fizycznie od PC i radia )
BUS- 0V
BUS+ 5VDC
BUSY 5VDC
BUSY_ 0V
TX 0V
RX 5VDC

Na linii bus- i bus+ podczas transmisji, słucha i formuje sygnał układ CA3140E. Załączniki wysłałem via email.

_________________
Pozdrawiam Łukasz SQ3NQH
  
SQ3NQH
09.05.2016 13:30:28
poziom 2

Grupa: Użytkownik

QTH: Krotoszyn JO81RQ

Posty: 65 #2281192
Od: 2011-4-17
W GM900 dany kanał może mieć swoją nazwę a właściwie to 2 znaki wyświetlane na wyświetlaczu w celu identyfikacji kanału. Nie ma znaczenia z jakiego kanału a właściwie wyświetlanych znaków radio startuje. Rezerwuj czas na spotkanie ŁOŚ 2016, ja będę od czwartku. RIB i kable będą na górce ze mną, energia elektryczna również. aniołek
_________________
Pozdrawiam Łukasz SQ3NQH
  
VSS
09.05.2016 15:52:23
poziom najwyższy i najjaśniejszy :-)



Grupa: Użytkownik

QTH: Posen

Posty: 2299 #2281256
Od: 2009-12-24


Ilość edycji wpisu: 3
właśnie zaprogramowałem gm900 dla SR3X bo chyba zdechło, komp - thinkpad z celeronem, bez żadnego spowalniania, kabel z batlabs podłączany do mikrofonu, oryginalny RIB. żadnych problemów, wszystko od pierwszego kopa.

Obrazek

WAŻNA SPRAWA: POPATRZ NA KABEL Z RIB'A DO MIKROFONU: AMERYKAŃCE ODWROTNIE NUMERUJĄ PINY wesoły
_________________
Artur VSS
http://sp3vss.pl http://vss.pl
PZK - Piraci Z Karaibów

zarejestruj się i kupuj w tysiącach sklepów jeszcze taniej!
https://www.tipli.pl/p/188175
  
SP9MK
09.05.2016 17:14:46
poziom 4

Grupa: Użytkownik

QTH: Mysłowice

Posty: 349 #2281294
Od: 2016-5-4
Motorolka odczytana!

Obecny zestaw to:
Komputer 320Mb ram 600MHz celeron. Kabelek na MAX3232 + LM211(odpowiednik LM311). Kabel mojego pomysłu.

Dla potomnych. RSS przez skopiowanie i odpalenie nie rusza!
Należy go zainstalować z katalogu install wpisując komendę install.bat c: (gdzie c: to dysk na który mają być skopiowane pliki).

Pozostaje przejść na programowanie via RJ45 a później USB itp o czym będę informował.

SQ3NQH Twój film okazał się bezcenny. Nie kasuj z YT przyda się innym wesoły
  
SP9MK
18.05.2016 18:37:18
poziom 4

Grupa: Użytkownik

QTH: Mysłowice

Posty: 349 #2285328
Od: 2016-5-4
Jako, że trochę czasu minęło a miałem pochwalić się efektami to przedstawiam prototyp V0.1, którym "odpalił" i obecną wersję V1.0.

Obrazek

Obrazek
  
Electra20.08.2018 02:46:10
poziom 5

oczka

Przejdz do góry stronyStrona: 1 / 1    strony: [1]

  << Pierwsza      < Poprzednia      Następna >     Ostatnia >>  

HOME » DIY - KONSTRUKCJE » MOTOROLA GM900 I PROBLEMY...

Aby pisac na forum musisz sie zalogować !!!

randki | własny sklep internetowy | promocje | CyberCiekawostki | darmowe forum | sklepy
opinie, testy, oceny | katalog stron | toplsta